ORMBr Fórum - Seja bem vindo
Problemas com Association - Versão de Impressão

+- ORMBr Fórum - Seja bem vindo (https://www.ormbr.com.br/forum)
+-- Fórum: Fórum ORMBr - Aberto (https://www.ormbr.com.br/forum/forumdisplay.php?fid=1)
+--- Fórum: Como Usar (https://www.ormbr.com.br/forum/forumdisplay.php?fid=6)
+--- Tópico: Problemas com Association (/showthread.php?tid=43)



Problemas com Association - Lucas Souto - 05-03-2018

Eu estou com um problema nas minhas entidades e queria saber se alguém sabe o porque. O que acontece, eu tenho três entidades onde uma é atendimento que tem associação para exame e exame tem associação para procedimento, o problema é que quando eu crio atendimento ele cria exame mas não cria procedimento e quando tento acessar o objeto procedimento que era para estar criado e carregado dá um access violation.

Segue o link do projeto que isolei da minha aplicação original que tem o mesmo comportamento que citei. Também já vai o dump de uma base no PostgreSQL para testes.

https://github.com/lucassouto/exemplo_ormbr


RE: Problemas com Association - Isaque Pinheiro - 22-04-2018

(05-03-2018, 04:54 PM)Lucas Souto Escreveu: Eu estou com um problema nas minhas entidades e queria saber se alguém sabe o porque. O que acontece, eu tenho três entidades onde uma é atendimento que tem associação para exame e exame tem associação para procedimento, o problema é que quando eu crio atendimento ele cria exame mas não cria procedimento e quando tento acessar o objeto procedimento que era para estar criado e carregado dá um access violation.

Segue o link do projeto que isolei da minha aplicação original que tem o mesmo comportamento que citei. Também já vai o dump de uma base no PostgreSQL para testes.

https://github.com/lucassouto/exemplo_ormbr

Analise sua situação pelo link http://www.ormbr.com.br/forum/showthread.php?tid=44 e veja se resolve.


RE: Problemas com Association - Odlawso - 11-09-2018

(22-04-2018, 02:15 PM)Isaque Pinheiro Escreveu:
(05-03-2018, 04:54 PM)Lucas Souto Escreveu: Eu estou com um problema nas minhas entidades e queria saber se alguém sabe o porque. O que acontece, eu tenho três entidades onde uma é atendimento que tem associação para exame e exame tem associação para procedimento, o problema é que quando eu crio atendimento ele cria exame mas não cria procedimento e quando tento acessar o objeto procedimento que era para estar criado e carregado dá um access violation.

Segue o link do projeto que isolei da minha aplicação original que tem o mesmo comportamento que citei. Também já vai o dump de uma base no PostgreSQL para testes.

https://github.com/lucassouto/exemplo_ormbr

Analise sua situação pelo link http://www.ormbr.com.br/forum/showthread.php?tid=44 e veja se resolve.

Boa tarde.
Estou com o mesmo problema e não consegui acessar o link indicado.
Conseguiu solucionar seu problema, Lucas?


RE: Problemas com Association - Isaque Pinheiro - 11-09-2018

(11-09-2018, 03:41 PM)Odlawso Escreveu:
(22-04-2018, 02:15 PM)Isaque Pinheiro Escreveu:
(05-03-2018, 04:54 PM)Lucas Souto Escreveu: Eu estou com um problema nas minhas entidades e queria saber se alguém sabe o porque. O que acontece, eu tenho três entidades onde uma é atendimento que tem associação para exame e exame tem associação para procedimento, o problema é que quando eu crio atendimento ele cria exame mas não cria procedimento e quando tento acessar o objeto procedimento que era para estar criado e carregado dá um access violation.

Segue o link do projeto que isolei da minha aplicação original que tem o mesmo comportamento que citei. Também já vai o dump de uma base no PostgreSQL para testes.

https://github.com/lucassouto/exemplo_ormbr

Analise sua situação pelo link http://www.ormbr.com.br/forum/showthread.php?tid=44 e veja se resolve.

Boa tarde.
Estou com o mesmo problema e não consegui acessar o link indicado.
Conseguiu solucionar seu problema, Lucas?

Link atualizado veja se consegue acessa-lo agora, veja também o exemplo na pasta "..\ORMBr\Demo\Data\Object Lazy" usei as mesmas entidades desse poste para mostrar relacionamento em vários níveis, assim como acessa-lo em carga tardia.


RE: Problemas com Association - Isaque Pinheiro - 12-09-2018

(11-09-2018, 03:41 PM)Odlawso Escreveu:
(22-04-2018, 02:15 PM)Isaque Pinheiro Escreveu:
(05-03-2018, 04:54 PM)Lucas Souto Escreveu: Eu estou com um problema nas minhas entidades e queria saber se alguém sabe o porque. O que acontece, eu tenho três entidades onde uma é atendimento que tem associação para exame e exame tem associação para procedimento, o problema é que quando eu crio atendimento ele cria exame mas não cria procedimento e quando tento acessar o objeto procedimento que era para estar criado e carregado dá um access violation.

Segue o link do projeto que isolei da minha aplicação original que tem o mesmo comportamento que citei. Também já vai o dump de uma base no PostgreSQL para testes.

https://github.com/lucassouto/exemplo_ormbr

Analise sua situação pelo link http://www.ormbr.com.br/forum/showthread.php?tid=44 e veja se resolve.

Boa tarde.
Estou com o mesmo problema e não consegui acessar o link indicado.
Conseguiu solucionar seu problema, Lucas?

Bom dia

Acabei de subir um exemplo mostrando usar vários níveis como está tendo problema, atualize seus fontes e olhe na pasta "..\ORMBr\Demo\Data\Quatro Niveis de Dados"