Avaliação do Tópico:
  • 0 votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Problemas com Association
#1
Eu estou com um problema nas minhas entidades e queria saber se alguém sabe o porque. O que acontece, eu tenho três entidades onde uma é atendimento que tem associação para exame e exame tem associação para procedimento, o problema é que quando eu crio atendimento ele cria exame mas não cria procedimento e quando tento acessar o objeto procedimento que era para estar criado e carregado dá um access violation.

Segue o link do projeto que isolei da minha aplicação original que tem o mesmo comportamento que citei. Também já vai o dump de uma base no PostgreSQL para testes.

https://github.com/lucassouto/exemplo_ormbr
Responder
#2
(05-03-2018, 04:54 PM)Lucas Souto Escreveu: Eu estou com um problema nas minhas entidades e queria saber se alguém sabe o porque. O que acontece, eu tenho três entidades onde uma é atendimento que tem associação para exame e exame tem associação para procedimento, o problema é que quando eu crio atendimento ele cria exame mas não cria procedimento e quando tento acessar o objeto procedimento que era para estar criado e carregado dá um access violation.

Segue o link do projeto que isolei da minha aplicação original que tem o mesmo comportamento que citei. Também já vai o dump de uma base no PostgreSQL para testes.

https://github.com/lucassouto/exemplo_ormbr

Analise sua situação pelo link http://www.ormbr.com.br/forum/showthread.php?tid=44 e veja se resolve.

  Isaque Pinheiro
  Fundador do Projeto ORM Brasil
  ORMBr SAC - Assine e faça parte dessa história ajudando o projeto a crescer.

Responder
#3
(22-04-2018, 02:15 PM)Isaque Pinheiro Escreveu:
(05-03-2018, 04:54 PM)Lucas Souto Escreveu: Eu estou com um problema nas minhas entidades e queria saber se alguém sabe o porque. O que acontece, eu tenho três entidades onde uma é atendimento que tem associação para exame e exame tem associação para procedimento, o problema é que quando eu crio atendimento ele cria exame mas não cria procedimento e quando tento acessar o objeto procedimento que era para estar criado e carregado dá um access violation.

Segue o link do projeto que isolei da minha aplicação original que tem o mesmo comportamento que citei. Também já vai o dump de uma base no PostgreSQL para testes.

https://github.com/lucassouto/exemplo_ormbr

Analise sua situação pelo link http://www.ormbr.com.br/forum/showthread.php?tid=44 e veja se resolve.

Boa tarde.
Estou com o mesmo problema e não consegui acessar o link indicado.
Conseguiu solucionar seu problema, Lucas?
Responder
#4
(11-09-2018, 03:41 PM)Odlawso Escreveu:
(22-04-2018, 02:15 PM)Isaque Pinheiro Escreveu:
(05-03-2018, 04:54 PM)Lucas Souto Escreveu: Eu estou com um problema nas minhas entidades e queria saber se alguém sabe o porque. O que acontece, eu tenho três entidades onde uma é atendimento que tem associação para exame e exame tem associação para procedimento, o problema é que quando eu crio atendimento ele cria exame mas não cria procedimento e quando tento acessar o objeto procedimento que era para estar criado e carregado dá um access violation.

Segue o link do projeto que isolei da minha aplicação original que tem o mesmo comportamento que citei. Também já vai o dump de uma base no PostgreSQL para testes.

https://github.com/lucassouto/exemplo_ormbr

Analise sua situação pelo link http://www.ormbr.com.br/forum/showthread.php?tid=44 e veja se resolve.

Boa tarde.
Estou com o mesmo problema e não consegui acessar o link indicado.
Conseguiu solucionar seu problema, Lucas?

Link atualizado veja se consegue acessa-lo agora, veja também o exemplo na pasta "..\ORMBr\Demo\Data\Object Lazy" usei as mesmas entidades desse poste para mostrar relacionamento em vários níveis, assim como acessa-lo em carga tardia.

  Isaque Pinheiro
  Fundador do Projeto ORM Brasil
  ORMBr SAC - Assine e faça parte dessa história ajudando o projeto a crescer.

Responder
#5
(11-09-2018, 03:41 PM)Odlawso Escreveu:
(22-04-2018, 02:15 PM)Isaque Pinheiro Escreveu:
(05-03-2018, 04:54 PM)Lucas Souto Escreveu: Eu estou com um problema nas minhas entidades e queria saber se alguém sabe o porque. O que acontece, eu tenho três entidades onde uma é atendimento que tem associação para exame e exame tem associação para procedimento, o problema é que quando eu crio atendimento ele cria exame mas não cria procedimento e quando tento acessar o objeto procedimento que era para estar criado e carregado dá um access violation.

Segue o link do projeto que isolei da minha aplicação original que tem o mesmo comportamento que citei. Também já vai o dump de uma base no PostgreSQL para testes.

https://github.com/lucassouto/exemplo_ormbr

Analise sua situação pelo link http://www.ormbr.com.br/forum/showthread.php?tid=44 e veja se resolve.

Boa tarde.
Estou com o mesmo problema e não consegui acessar o link indicado.
Conseguiu solucionar seu problema, Lucas?

Bom dia

Acabei de subir um exemplo mostrando usar vários níveis como está tendo problema, atualize seus fontes e olhe na pasta "..\ORMBr\Demo\Data\Quatro Niveis de Dados"

  Isaque Pinheiro
  Fundador do Projeto ORM Brasil
  ORMBr SAC - Assine e faça parte dessa história ajudando o projeto a crescer.

Responder


Possíveis Tópicos Relacionados...
Tópico: Autor Respostas: Visualizações: Última Mensagem
  Problemas de execução e testes Dalton 1 2,257 27-03-2017, 05:23 PM
Última Mensagem: Isaque Pinheiro
  Como utilizar [Association] leandroandreotti 1 2,360 14-12-2016, 05:25 PM
Última Mensagem: Isaque Pinheiro

Saltar Fórum:


usuários a ver este tópico: 1 Visitante(s)